Monthly Archive for gener, 2007

Nou iPhone, senzillament brutal!!!

Feia molt de temps que corria el rumor d'un telèfon apple i ahir per fi es va revel·lar…. el telèfon es diu iPhone. Semblava que finalment no seria iPhone el nom, ja que linksys, la filial de cisco va treure un telèfon ip amb aquest nom, però segons sembla avui apple ja ho ha arreglat amb cisco.

Bé doncs aquí us deixo algunes fotos de l'impressionat aparell:

Imatge de l'iPhone per darrera, la poso en primicia perquè no és fàcil de trobar
iPhone per darrera

iPhone amb el navegador Safari adaptat a l'OS X “mobile”
Imatge de l'iPhone executant el Safari

Pantalla de l'iPhone mostrant algun dels widgets que incorpora
Pantalla de l'iPhone mostrant algun dels widgets que incorpora

Teclat per marcar números de telèfon de l'iPhone, no és telèfon 3G, però té wi-fi 11n i bluetooth 2.0
Teclat per marcar telèfons

Instal·lar pico per a Debian etch

Pico és un editor de text en mode consola. Fins ara utilitzava el nano que és un clon GNU d'aquest, però això de la genètica no m'agrada gaire i pel que he vist com l'original no hi ha res. Amb el nano quan editava un fitxer se'm distorsionava el text que es veia per la pantalla. La pega del pico és la llicència que té ja que és molt restrictiva, per aquest motiu es va desenvolupar l'editor nano.
En el meu cas he hagut de compilar un paquet perquè la màquina era un amd64 i el paquet debian que hi ha a la web del pico/pine és per la plataforma i386.

1. Per compilar el paquet debian ens descarreguem les fonts i les descomprimim:

#cd /usr/src

#wget ftp://ftp.cac.washington.edu/pine/pine.tar.bz2

#tar -jxf pine.tar.bz2

2. Preparem les fonts per generar el paquet .deb

#cd pine4.64/packages
#cp -pr debian ../
#cd ..

3. Generem el paquet

#dpkg-buildpackage
#cd ..

Nota:
Si hi ha alguna dependència sense satisfer sortirà un missatge semblant a aquest:

dpkg-checkbuilddeps: Unmet build dependencies: libpam-dev | libpam0g-dev

Caldrà doncs satisfer-les i tornar a generar el paquet:

#apt-get install libpam-dev libpam0g-dev

#dpkg-buildpackage

4. Per últim instal·lem el nou paquet

#dpkg -i pine_4.64_amd64.deb